[UK & Europe] [LIVE] Scheduled Maintenance

Scheduled for Nov 14, 21:00 UTC  -  Nov 16, 05:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 20, 2025 - 22:00 UTC

Scheduled

Please be advised of upcoming scheduled maintenance that will impact your use of 3E Cloud LIVE environment.

Scheduled Maintenance will be performed on Friday, November 14th, and Saturday, November 15th, during the maintenance windows only (9PM TO 5AM GMT).

Components to be updated:

- 3E (Core) 5.9.0 (including OData APIs and UI)
- 3E Proforma (P) 7.14.0
- 3E Templates (T) 4.15.0
- Other supporting components (including 3E Cloud Management Tool (CMT) 1.25.0))

During the maintenance windows indicated above, the 3E Cloud components noted may be unavailable in your LIVE environment. Should the time extend beyond the projected window, updates will be communicated via Statuspage.
Posted Oct 20, 2025 - 21:56 UTC
This scheduled maintenance affects: UK (3E CORE, 3E PROFORMA, 3E TEMPLATES, SUPPORTING COMPONENTS) and EUROPE (3E CORE, 3E PROFORMA, 3E TEMPLATES, SUPPORTING COMPONENTS).