3E and 3E Workspace - partial outage/degraded performance

Incident Report for Elite 3E

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 14:33 UTC

Monitoring

The issue impacting some customers has been resolved, and services are now operating normally. Our teams continue to investigate the root cause and are working on preventing recurrence. We are closely monitoring system performance and will provide an update once the investigation is complete.
Posted Oct 23, 2025 - 18:55 UTC

Investigating

We are currently investigating an issue that is impacting some customers. Our teams are actively working to identify the affected resource and determine the root cause. We will provide an update as soon as more information becomes available.
Posted Oct 23, 2025 - 18:15 UTC
This incident affected: USA (3E CORE, 3E WORKSPACE).